Plupload browse button is not working in safari

I am using plupload of version- 2. In a Ruby on Rails application. Browse button(that leads to the opening of a open file dialog box) is not working in Safari but everything is working fine in Firefox and Chrome. Here is the sight of my code :

    $(document).ready(function(){
            var uploader = new plupload.Uploader({
            runtimes                                        :       'html5',
            browse_button                   :       'upload-pinboard-pic',
            container                               :       'uploader_contianer',
            url                                             :       '/galleries',
            filters                                 :       [{title : "Image files", extensions : "jpg,gif,png"}],
            autostart                               :       true,
            multipart                               :       true,
            multipart_params                :       {'class_type': 'BoardPic',
                                                                            '_http_accept': 'application/javascript',
                                                                            '_method': 'post',
                                                                            'action' : 'create',
                                                                            'controller' :'galleries',
                                                                            '<%= Rails.application.config.session_options[:key] %>' : encodeURIComponent('<%= u cookies[Rails.application.config.session_options[:key]] %>'),
                                                                            'authenticity_token': '<%= form_authenticity_token %>'}
            });

            uploader.init();

            uploader.bind('FilesAdded', function(up, files){
                    if (files[0].size>1048576){
                        uploader.splice();
                        $("#dialog-confirm span").html('Photo must be less than 1 MB');
                            $("#dialog-confirm").dialog({
                            autoOpen: false,
                            resizable: false,
                            modal: true,
                            buttons: {
                                    "Ok": function() {
                                            $("#dialog-confirm").dialog("close");
                                            return false;
                                    },
                            }
                       });
                      weunite_modal_dialog();
                    }
                    else{
                    $("#uploading_image").show();
                    up.start();
                    }
            });

            uploader.bind('FileUploaded', function(up, file, info){
                    jsonObject = jQuery.parseJSON(info["response"]);
        $("#uploading_image").hide();
                    if (jsonObject['error']){
            $("#dialog-confirm span").html(jsonObject['error']);
              $( "#dialog-confirm" ).dialog({
                    autoOpen: false,
                    resizable: false,
                    modal: true,
                    buttons: {
                            "Ok": function(){
                                    $('#dialog-confirm').dialog("close");
                            }
                    }
              });
             weunite_modal_dialog();
            }else{
                    $("#uploaded-file").attr('src', jsonObject['orig_url']);
                    var url = jsonObject['orig_url'];
                    $('#board-image-file').val(url);
                    $("#newBoard-attachmentID").val(jsonObject['attachment_id']);
                   }
            });
    });

Thanks in advance.

Using Plupload to upload files, browse_button stops working

I have found that when the browse_button gets moved on the screen (possibly due to dynamic content), it doesn’t work anymore and needs a Uploader.refresh() call (mentioned on the plupload forum). I ha

plupload browse_button not showing browse dialog

I’m using plupload queue to upload images to our server. I am setting the value of browse_button to the id of a hyperlink, so it shows a browse dialog box. But when I click that hyperlink, nothing sho



Plupload browse button doesn’t work in IE9

I’m trying to make plupload running in IE9. Here is my html: <div id=uploader> <a id=browse href=javascript:;>Browse…</a> <a id=upload href=javascript:;>Upload…

Plupload browse buton doesn’t work in IE10

I just put up a simple file upload with JS Plupload plugin system. Just a button that opens the file explorer to select the file to download. The system works in Chrome, Firefox, Safari but not in Int

Magento browse files button not working

Magento Upload Image Issue : When I click on Browse Files button to upload images for a product. It is not browsing files from my computer.

Browse Button required?

Hii i am working on an application in which i require to select files using browse button.. How can i implement a browse button in android?

easiest possible plupload configuration and yet not working

I’ve just copied the plupload getting started example in a *.html file, and still can’t have the browse feature working. Clicking on ‘browse’ link doesn’t do anything. The plupload.full.min.js is in t

browse or select file button disable in iphone safari browser

I want to know why select file or choose file button is disable when a web page is view in iphone safari. Can anyone tell explain me why this happens is there any way to enable it ?? Thanks

Editing a browse button

I have a browse button that I want to edit. Here is how I made it: <input type = file id = myBrowseButton class = BrowseButtons name = Browse /> The button looks like you regular browse

Echoing value using AJAX for plupload

Hi This is my JS file for plupload var uploader = new plupload.Uploader({ runtimes : ‘html5,flash,silverlight,html4’, browse_button : ‘pickfiles’, // you can pass in id… container: document.getEleme

Answers

I don’t know how it works I just change the value of the class and Id of the browse button element. May be the the Id/class conflict was the reason.