Issue upgrading ember 2.8 to 2.11 – cannot find module 'ember'

I believe this is somehow related to how Ember is now setup through npm instead of bower.

After upgrading my application (working fine previously on lts 2.8) to 2.11 using this process:

https://github.com/ember-cli/ember-cli/releases/tag/v2.11.0

I was relatively meticulous incorporating the diffs while going through ember init and have checked my app against the current ember-cli blueprint for 2.11:

https://github.com/ember-cli/ember-cli/tree/v2.11.0/blueprints/app/files

And yet upon load I get in the console:

Uncaught Error: Could not find module ’ember’ imported from ‘(require)’

I noticed bower.json still had “ember”: “lts-2-8” in it, but removing it seemed to have no effect.

Is there some other step now that ember is installed through npm?

From package.json:
“ember-cli”: “2.11.0”
“ember-source”: “^2.11.0”

EDIT:

ember-let seemed to cause one of these errors, but even with removing this from package.json, still seeing this one:

```
Uncaught Error: Could not find module `ember` imported from `*/app`
    at missingModule (loader.js:239)
    at findModule (loader.js:250)
    at Module.findDeps (loader.js:190)
    at findModule (loader.js:253)
    at requireModule (loader.js:20)
    at app-boot.js:4
```

Try moving ember-cli-shims from bower.json to package.json

You can very well check and confirm for the changes between 2.8 to 2.11.
https://github.com/ember-cli/ember-new-output/compare/v2.8.0…v2.11.0